18 lines
431 B
Nix
18 lines
431 B
Nix
{ config, pkgs, ... }:
|
|
{
|
|
imports = [
|
|
../../../deployments/transfer-sh/module.nix
|
|
];
|
|
|
|
services.transfer-sh = {
|
|
enable = true;
|
|
openFirewall = true;
|
|
address = "192.168.99.201";
|
|
HTTP_AUTH_HTPASSWD = "/run/secrets/services/nginx/transfersh.htpasswd";
|
|
TEMP_PATH = "/mnt/data/transfer-sh/temp";
|
|
BASEDIR = "/mnt/data/transfer-sh/store";
|
|
EMAIL_CONTACT = "abuse@lewd.wtf";
|
|
PURGE_DAYS = "90";
|
|
};
|
|
}
|